Commit a42e266d authored by CompileNix's avatar CompileNix

update deps

parent cb8ed0aa
......@@ -175,6 +175,15 @@
"concat-map": "0.0.1"
}
},
"bufferutil": {
"version": "4.0.1",
"resolved": "https://registry.npmjs.org/bufferutil/-/bufferutil-4.0.1.tgz",
"integrity": "sha512-xowrxvpxojqkagPcWRQVXZl0YXhRhAtBEIq3VoER1NH5Mw1n1o0ojdspp+GS2J//2gCVyrzQDApQ4unGF+QOoA==",
"optional": true,
"requires": {
"node-gyp-build": "~3.7.0"
}
},
"builtin-modules": {
"version": "1.1.1",
"resolved": "https://registry.npmjs.org/builtin-modules/-/builtin-modules-1.1.1.tgz",
......@@ -1001,9 +1010,9 @@
"dev": true
},
"jquery": {
"version": "3.2.1",
"resolved": "https://registry.npmjs.org/jquery/-/jquery-3.2.1.tgz",
"integrity": "sha1-XE2d5lKvbNCncBVKYxu6ErAVx4c="
"version": "3.3.1",
"resolved": "https://registry.npmjs.org/jquery/-/jquery-3.3.1.tgz",
"integrity": "sha512-Ubldcmxp5np52/ENotGxlLe6aGMvmF4R8S6tZjsP6Knsaxd/xp3Zrh50cG93lR6nPXyUFwzN3ZSOQI0wRJNdGg=="
},
"js-tokens": {
"version": "4.0.0",
......@@ -1157,6 +1166,12 @@
"integrity": "sha512-1nh45deeb5olNY7eX82BkPO7SSxR5SSYJiPTrTdFUVYwAl8CKMA5N9PjTYkHiRjisVcxcQ1HXdLhx2qxxJzLNQ==",
"dev": true
},
"node-gyp-build": {
"version": "3.7.0",
"resolved": "https://registry.npmjs.org/node-gyp-build/-/node-gyp-build-3.7.0.tgz",
"integrity": "sha512-L/Eg02Epx6Si2NXmedx+Okg+4UHqmaf3TNcxd50SF9NQGcJaON3AtU++kax69XV7YWz4tUspqZSAsVofhFKG2w==",
"optional": true
},
"normalize-package-data": {
"version": "2.4.0",
"resolved": "https://registry.npmjs.org/normalize-package-data/-/normalize-package-data-2.4.0.tgz",
......@@ -1936,6 +1951,15 @@
"resolved": "https://registry.npmjs.org/use-strict/-/use-strict-1.0.1.tgz",
"integrity": "sha1-C7gNlPSaSgUZK4Sox9NOlfGn46A="
},
"utf-8-validate": {
"version": "5.0.2",
"resolved": "https://registry.npmjs.org/utf-8-validate/-/utf-8-validate-5.0.2.tgz",
"integrity": "sha512-SwV++i2gTD5qh2XqaPzBnNX88N6HdyhQrNNRykvcS0QKvItV9u3vPEJr+X5Hhfb1JC0r0e1alL0iB09rY8+nmw==",
"optional": true,
"requires": {
"node-gyp-build": "~3.7.0"
}
},
"validate-npm-package-license": {
"version": "3.0.4",
"resolved": "https://registry.npmjs.org/validate-npm-package-license/-/validate-npm-package-license-3.0.4.tgz",
......
......@@ -3,26 +3,22 @@
"version": "0.2.0",
"description": "dump stuff to console or webclient (using websocket).",
"author": "Compilenix <Compilenix@compilenix.org>",
"license": "MIT",
"repository": {
"type": "git",
"url": "https://git.compilenix.org/Compilenix/http-dump.git"
},
"bugs": "https://git.compilenix.org/Compilenix/http-dump/issues",
"main": "app.js",
"scripts": {
"start": "npm install && node app.js"
},
"dependencies": {
"htmlencode": "*",
"jquery": "*",
"htmlencode": "0.0.4",
"jquery": "^3.3.1",
"use-strict": "^1.0.1",
"ws": "^2.3.1"
},
"license": "MIT",
"repository": {
"type": "git",
"url": "https://git.compilenix.org/Compilenix/http-dump.git"
},
"bugs": "https://git.compilenix.org/Compilenix/http-dump/issues",
"optionalDependencies": {
"bufferutil": "^3.0.0",
"utf-8-validate": "^3.0.1"
},
"devDependencies": {
"eslint": "^5.12.0",
"eslint-config-standard": "^12.0.0",
......@@ -31,5 +27,9 @@
"eslint-plugin-promise": "^4.0.1",
"eslint-plugin-standard": "^4.0.0",
"standard": "^12.0.1"
},
"optionalDependencies": {
"bufferutil": "^4.0.1",
"utf-8-validate": "^5.0.2"
}
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment